Use   Microsoft Internet Explorer 8.0 & above  for better performance & security